Ansicht von 2 Antwort-Themen
  • Autor
    • #11901


        I have one problem with freshly installed OTOBO 10.0.12.

        It’s standalone Apache Installation on AlmaLinux 8.4.

        Everything seems to work fine, except one thing. In WebInterface of OTOBO in Admin section, when I click on ‘System log’, it just says ”No data found. “.
        But OTOBO is logging fine to the syslog.
        Current settings in (I started to fiddle with this after I found it does not work):

        $Self->{LogModule} = 'Kernel::System::Log::SysLog';
        $Self->{'LogModule::SysLog::Facility'} = 'local0';
        $Self->{'LogModule::SysLog::Charset'} = 'utf-8';

        When I set logging to file, logging to file is OK too. But nothing is visible from WebInterface.

        Any ideas what could be wrong?


        I have another one instance of OTOBO for testing. But it’s on CentOS 7.9 and was installed as version 10.0.7, with several updates and now it’s 10.0.12 too. But ‘System log’ is displaying normally here.

      • #11904

          Just a quick update. I was trying to make both instances same as the other.

          When I installed packages FAQ and ITSM (I had them in older installation) from OTOBO repository. ‘System Log’ started working miraculously.


          If there is some explanation for this, I would be glad.

        • #11905

            Hi Kisuke,

            I just tried it in test installation and of course it worked find there. My hunch is that this should not depend on the log settings. This is because the data shown in the GUI is taken from a shared memory segment. The data is written into shared memory as a intended side effect of logging.

            Perhaps you could narrow it down by trying these OTOBO console commands:

            • bin/ Maint::Log::Print    for printing the log  in the command line
            • bin/ Maint::Log::Clear  for clearing the log

            I hope that helps,





        Ansicht von 2 Antwort-Themen
        • Du musst angemeldet sein, um auf dieses Thema antworten zu können.