Schlagwörter: ,

Ansicht von 0 Antwort-Themen
  • Autor
    • #13558
      Mathias Rumbold

        Hello together,

        when I try to run the elasticsearch migration on otobo 10.1.4 I get the following error:
        otobo@otobo01:~/bin$ ./ Maint::Elasticsearch::Migration
        Use of uninitialized value in numeric ne (!=) at /opt/otobo/Kernel/System/Console/Command/Maint/Elasticsearch/ line 98.
        Elasticsearch webservice is now activated. If you don’t want to keep it enabled, please disable it manually in the admin interface, after the migration is complete.
        ERROR: Perl: 5.30.0 OS: linux Time: Tue Aug 16 10:54:04 2022

        Message: Need ID!

        Traceback (195867):
        Module: Kernel::System::GenericInterface::Webservice::WebserviceUpdate Line: 324
        Module: Kernel::System::Console::Command::Maint::Elasticsearch::Migration::PreRun Line: 103
        Module: (eval) Line: 465
        Module: Kernel::System::Console::BaseCommand::Execute Line: 465
        Module: Kernel::System::Console::InterfaceConsole::Run Line: 88
        Module: ./ Line: 35

        Elasticsearch webservice could not be activated! Unable to continue.
        Error: Died at /opt/otobo/Kernel/System/Console/Command/Maint/Elasticsearch/ line 110.

        Does anyone else has the same error and solved it?


        I did a migration from otrs to otobo 10.0.x and then migrated to otobo 10.1.4. I just configured the elasticsearch as written in the otobo wiki and then I also checked if everything is listening on port http://localhost:9200

        curl -i http://localhost:9200
        HTTP/1.1 200 OK
        X-elastic-product: Elasticsearch
        Warning: 299 Elasticsearch-7.17.5-8d61b4f7ddf931f219e3745f295ed2bbc50c8e84 “Elasticsearch built-in security features are not enabled. Without authentication, your cluster could be accessible to anyone. See to enable security.”
        content-type: application/json; charset=UTF-8
        content-length: 556

        “name” : “”,
        “cluster_name” : “elasticsearch”,
        “cluster_uuid” : “TtpgbfxwSQKudMg48UaDRA”,
        “version” : {
        “number” : “7.17.5”,
        “build_flavor” : “default”,
        “build_type” : “deb”,
        “build_hash” : “8d61b4f7ddf931f219e3745f295ed2bbc50c8e84”,
        “build_date” : “2022-06-23T21:57:28.736740635Z”,
        “build_snapshot” : false,
        “lucene_version” : “8.11.1”,
        “minimum_wire_compatibility_version” : “6.8.0”,
        “minimum_index_compatibility_version” : “6.0.0-beta1”
        “tagline” : “You Know, for Search”

        I also installed both plugins. Do I need to check the admin interface of elasticsearch?

        I use:
        Ubuntu 20.04.4
        apache2-bin/focal-updates,focal-security,now 2.4.41-4ubuntu3.12 amd64 [installed,automatic]
        apache2-data/focal-updates,focal-security,now 2.4.41-4ubuntu3.12 all [installed,automatic]
        apache2-utils/focal-updates,focal-security,now 2.4.41-4ubuntu3.12 amd64 [installed,automatic]
        apache2/focal-updates,focal-security,now 2.4.41-4ubuntu3.12 amd64 [installed]
        libapache2-mod-perl2/focal-updates,now 2.0.11-2ubuntu0.20.04.1 amd64 [installed]
        libapache2-reload-perl/focal,now 0.13-3 all [installed,automatic]

    Ansicht von 0 Antwort-Themen
    • Du musst angemeldet sein, um auf dieses Thema antworten zu können.